+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12

Thread: Turkeytopia quest cannot complete

  1. #11
    Senior Member TheDeadEye's Avatar
    Join Date
    Sep 2015
    Thanks. Now at 6/7 and still stuck. *sigh*

    Woo, husband of AJo | Mastery: 700+ | President of Garden of Wool | Alpha - Knight Supporter

  2. #12
    Junior Member
    Join Date
    Nov 2020
    Quote Originally Posted by OldGrumpy View Post
    Support answered, here is what they suggested and it worked for me:

    1) Start Glyph Launcher
    2) At the upper right, click on the triangle next to your account name to open the drop-down menu
    3) Click on "Log out"
    4) Close the launcher
    5) Start the launcher again
    6) Log in again
    7) Start Trove
    8) Quest should now display 7/7, just equip the mag rider and use it to solve the last quest.
    Time: Saturday, November 28, 2020 9:36 AM EST
    Context: Couldn't craft the: Sliced Slider because it is already in my collection so I'm stuck on 6/7
    Game details: the quest is Turkeytopia and the item I need to make but already have is Sliced Slider
    Expected: I expected to automatically pass the quest
    Observed: I tried equipping the Sliced Slider and it still didn't pass the quest
    Repro Steps: I followed the instructions in the quote above and it didn't work

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts