+ Reply to Thread
Results 1 to 3 of 3

Thread: Can't join Trove

  1. #1

    Can't join Trove

    Yesterday, after a long time don't playing trove (1 year) i was going to enter the game but when i tried to, a error happened. The error was "Connection timed out" i turned my internet off and then on but it still was glitched. i tried deleting the game and installing it again, it don't worked. i tried once more deleting Trove's data files (going into Configurations>Storage>Saved files) and loading the game but still didn't worked. I really don't know what to do.

  2. #2
    Junior Member
    Join Date
    May 2020
    Same with mine stuck in LS:Received user acknowlegment and then connection lost plz fix that sh*t

  3. #3
    user acknowledgement is easy to bypass just join of an invite while your game is closed me on the other hand have AS:LOogin and cant do anything

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts