+ Reply to Thread
Results 1 to 3 of 3

  Click here to go to the first Trove Team post in this thread.   Thread: i got a bug in the reliquary

  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    1

    Unhappy i got a bug in the reliquary

    i got a bug in geode reliquary that i can't even boost or do any for it the second i but it in the reliquary revealer it give me ready to collect and this video explain what i mean https://www.youtube.com/watch?v=pZ5DLHbWhUk i asked for help people said for me close mods and some said change the time i tried every thing and uses a lot of materials on it and still the same bug so that i would ask if you can help give me the solution of it because it stop my progress in the geode mastery
    sorry for the youtube video but iit's the only way to understand me

  2. #2
    Hi there,


    I think this one is a known issue that does happen sometimes I'm afraid.
    If you could kindly send the team a support ticket about not being able to open your reliquary, they will look into it for you.

    Please be patient though as there are many tickets to go through.

  3.   This is the last Trove Team post in this thread.   #3
    Community Manager Mobi's Avatar
    Join Date
    Jul 2019
    Posts
    281
    Thanks for reporting this and yes we do suggest putting in a support ticket for account related issues. Our team is also taking note of it and looking into it. If anyone else is getting this issue please let us know, thanks!

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts