It says I need to update version of Trove