+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

  Click here to go to the first Trove Team post in this thread.   Thread: PC/Xbox1 Restart - August 30, 2019

  1.   This is the last Trove Team post in this thread.   #1

    PC/Xbox1 Restart - August 30, 2019

    Hi all! We are bringing the PC and Xbox1 versions of Trove offline for a restart.

    PC will be restarted at 2:30 AM PT/9:30 AM UTC.

    Xbox1 will be restarted at 3:30 AM PT/10:30 AM UTC.

    Expected downtime is 1 hour for each environment, and thank you for your continued patience. We need to perform these restarts to get more information about reported instances of significant server lag.

    Update 3:05 AM PT: PC is now live! Xbox1 will start in 25 mins.

    Update: 3:50 AM PT: Xbox1 is live!

    Thank you for your patience, Trovians!

  2. #2
    Junior Member
    Join Date
    Jul 2015
    Posts
    13
    if its just testing hopefully it will only be an hour probably 3 hours but if you guys can fix the lag its worth it. this gives me time to read a few books.

  3. #3
    Junior Member Azelf_Willpower's Avatar
    Join Date
    Aug 2019
    Location
    United Kingdom
    Posts
    15
    Ugh, right as I was literally about to log in too. I've been Trove deprived for so long! But if it helps fix lag problems, then it's totally worth it and I fully understand. Another hour isn't going to kill me.




  4. #4
    So when you say 1 hour for testing, Do you really mean 3 days?


    I think everyone should get a Golden Dragon Effigy for this as compensation. *wink*

  5. #5
    Junior Member
    Join Date
    Aug 2019
    Posts
    19

  6. #6
    Junior Member
    Join Date
    Aug 2019
    Posts
    19
    I just woke up, excited to play trove, and i see this?

    I'm UTC +1

  7. #7
    Junior Member
    Join Date
    Jul 2015
    Posts
    13
    Impressive

  8. #8
    Junior Member
    Join Date
    Aug 2019
    Posts
    5
    really its down still ? again.. wtf...

  9. #9
    Junior Member
    Join Date
    Aug 2019
    Posts
    5
    well after 3 failed attempts i got in .. nvm i guess.. weird

  10. #10
    Servers are still lagging badly for me, lots of rubber banding and having to wait for worlds to build as I travel along. Also, frequent disconnects, many are when zoning but some just random and not related to zoning. Just an FYI, thanks for your continued hardwork to keep us playing!

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts