+ Reply to Thread
Results 1 to 4 of 4

Thread: Geode Cave Eggs not always registering

  1. #1
    Member
    Join Date
    Jul 2017
    Location
    Los Angeles
    Posts
    94

    Geode Cave Eggs not always registering

    I went into Moonglow Grotto and got to Tier 5. 1st lair was a crystal lair. Egg was on the middle plant thing. Grabbed egg, not mentioned on bottom right of screen. I checked inventory...not there.

    Second and third lairs were plant lairs. Grabbed those eggs and they counted.

    fourth lair was I think a ore lair. that egg counted.

    5th lair was a plant lair. Grabbed egg and it did NOT count.

    6th and final lair before I quit out of anger was another crystal lair. The egg was stuck in the middle of the middle column (which is BS as I had to lasermancy for a good minute to get it) and when I grabbed it, it did NOT count.

    Each one that did not count I heard the ding and the egg disappeared, but did not count in my inventory.

  2. #2
    Senior Member
    Join Date
    Apr 2017
    Posts
    323
    Yeah it's done this since day one of Geode Caves. I always wait a few seconds after "picking up" an egg to make sure I actually have it, if not it will re-appear and then I'll try again. It's dumb.

  3. #3
    Member
    Join Date
    Jul 2017
    Location
    Los Angeles
    Posts
    94
    Oh man lol. I never waited. I will try that next time. Never had this happen to me tbh.

    Thank you for letting me know.

  4. #4
    Senior Member kanamit's Avatar
    Join Date
    Jun 2017
    Posts
    113
    I always watch the screen and if it says I got a bronze egg then I move on. If not then I wait for it to reappear. I've also noticed that if it spawns inside blocks then its more likely to have to be reacquired, so I will zap away the blocks first. I've had nearly 100% success since doing this.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts