So, maybe you know that recently Proton has been released by Valve, which is a modified Wine with some extra stuff threw in. I wanted to play Trove since there is no Linux version. But it did not work. It is giving the "The FX file cannot be compiled" error when i click launch from Glyph or running the game .exe directly. I tried running it in Wine, same result. I have tried everything, such as downloading the game components via Winetricks, using Gallium Nine, CSMT, dxvk, but nothing works, everything gives the same one error. I also tried changing the renderer back and forth via the config file but no results.

Did anyone have this problem? Did you fix it? I think that the problem lies in the shaders, because another game (Dead Cells with DirectX) cannot run, but its OpenGL executable runs perfectly. As i said, i tried changing the renderer to OpenGL but it did not work. Maybe i did something wrong. I dunno. Anyways, if the game is not able to compile shaders (which i think is the issue), i think someone can lend me his/her compiled shader file? There is a folder in Application Data (in Users folder), called Trove, which has a "shaderscache" folder in it. If someone is kind enough to provide me that folder, i could try to see if it runs.