I bought a Club Rename Tag from the Marketplace(on 06.09.2018). I used it change my club world name from "THE GOLDEN KNIGHT KINGDOM" to a "The Camelot". Everything has worked without problems at the start, but I noticed that the "/joinworld The Camelot" command is not working correctly. The command "/joinword The Camelot" is teleporting a player to other empty club "the Camelot". I already tried the /renameworld command but it's not working.

I also tried to write the "/joinworld The Camelot" with a double spacebar, exclamation mark or big "i" instead of "l", none is working. The "/joinworld THE GOLDEN KNIGHT KINGDOM" is not working too.

You can join the the club world by using the "/joinworld 3281920807221142014" command, which is the world ID. but it's not comfortable for anyone to use it.

Today is October 4. I did sent a ticket to Trion(on 06.09.2018). After 28 day I still waiting for fix. They told to me "...Fortunately, that club should be removed from our system the next time the server restarts during the weekly maintenance period. Once that restart has happened, you should be able to update your club name normally." but i can't understand, they didn't any server(s) reset in all this time? because bug is still progress.

Here I attach 2 screenshots. One of them contain my club world's name( The Camelot ) on map, and other one is contain other club world's name( the Camelot ) on map.