+ Reply to Thread
Results 1 to 4 of 4

  Click here to go to the first Trove Team post in this thread.   Thread: An update isn't available is it?

  1. #1
    Member
    Join Date
    Jan 2017
    Location
    Somewhere
    Posts
    63

    An update isn't available is it?

    On several occasions I have been kicked from the game world and notified that I must "update the application to use network features."
    In order to resolve I must renew my ps4 licenses and relaunch. Please note that when checking the system reports that I have the current version.
    Is there a version conflict bug going on here?

  2.   Click here to go to the next Trove Team post in this thread.   #2
    Developers Phantasie's Avatar
    Join Date
    Dec 2015
    Location
    San Francisco
    Posts
    59
    Hi Xzellan

    Sony controls the distribution of patches (that we supply to them). So this dosent sound like a Trove specific problem, for what its worth. But Im happy to try to help!

    All patches are flagged as mandatory for network use (since Trove is an MMO of course). So that's why you see that message.

    Whats strange to me is why the PS4 isn't recognizing you need the patch when you launch the game - you shouldn't even be able to even launch the game - the OS would prevent it until you patch.

    A couple questions
    1. How often does this occur? The last Ps4 client patch was v1.24 released on April 18.
    2. Can you explain what you mean by "renew my ps4 licenses". If you mean "download a patch", well then this could be expected as you need to go from your current version (1.23, perhaps) to 1.24. If you mean delete the trove game and re-download the entire game from Sony, then thats unexpected.

    Thanks

    -- Phantasie

  3. #3
    Member
    Join Date
    Jan 2017
    Location
    Somewhere
    Posts
    63

    But I don't need the patch, that's the thing.

    Quote Originally Posted by Phantasie View Post
    Hi Xzellan

    Sony controls the distribution of patches (that we supply to them). So this dosent sound like a Trove specific problem, for what its worth. But Im happy to try to help!

    All patches are flagged as mandatory for network use (since Trove is an MMO of course). So that's why you see that message.

    Whats strange to me is why the PS4 isn't recognizing you need the patch when you launch the game - you shouldn't even be able to even launch the game - the OS would prevent it until you patch.

    A couple questions
    1. How often does this occur? The last Ps4 client patch was v1.24 released on April 18.
    2. Can you explain what you mean by "renew my ps4 licenses". If you mean "download a patch", well then this could be expected as you need to go from your current version (1.23, perhaps) to 1.24. If you mean delete the trove game and re-download the entire game from Sony, then thats unexpected.

    Thanks

    -- Phantasie
    Thank you for getting to me on this Phantasie, and I apologize for the confusion as I tend to mix humor in a bit, every now and again it can make for a scrambled report.
    The issue is that the game will kick me mid session about once every day to two days reporting suddenly that an update is available. After checking I find there is no update and that I already have the current version. I then must go into the Sony menu and renew licenses before the game will allow me to relog.
    I have heard others mention this happen to them and am familiar with Sony's process. Why it is happening is a mystery to me as well.

  4.   This is the last Trove Team post in this thread.   #4
    Developers Phantasie's Avatar
    Join Date
    Dec 2015
    Location
    San Francisco
    Posts
    59
    Hi Xzellan

    Thanks for the response. I think your best bet might be a ticket with Sony on this.

    In the meantime, when you're about to play Trove, check the version number (From the PS4 dashboard -> Library -> Trove -> Information (IIRC) ). Confirm its 1.24

    Then next time youre playing Trove and you get this error, exit the game completely and check the version number again. Since you say no update is available, its certainly sounds like it will still be 1.24 but Id like to confirm.

    This should isolate if its a versioning issue on the patch, or an entitlement issue on your account. Given that you need to renew licenses, it seems like the latter.

    Also: Are there any unique (that you can think of) things regarding your Trove account? For example did you play in the open Beta back in 2016/early 2017, quit and come back post Beta? Did you install the Beta on one PS4, quit, then install the game again on a new Ps4? Have you switched hardware multiple times? Did you change your PSN ID? I find it unlikely these would contribute, but its worth asking.

    I checked the Sony developer network and don't see any (obvious) questions from other devs about this behavior.

    If you want, PM me your PSN Name and Ill check our logs to see if the Sony entitlements for Trove on your account look correct (we cant change them, but we can give them a sanity check).

    I'm travelling next week so a response might be delayed.

    --Phantasie

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts