+ Reply to Thread
Results 1 to 4 of 4

Thread: How can I get trove running in linux mint 18.3 cinnamon?

  1. #1

    Question How can I get trove running in linux mint 18.3 cinnamon?

    please tell me,how do I get trove running in linux I want to play trove in linux thrugh wine and it just wont work no matter what! PLZ TELL ME WHAT IM DOING WRONG!!
    PSN:jmoruzzi07
    XBOX LIVE:none
    steam:TroveFan1
    youtube:john M

  2. #2
    Knowing where exactly you're stuck would be very useful to give you a precise answer.

    Generally, Trove itself works alright on wine (both DirectX and OpenGL, the former just had a few UI rendering issues last time I tried), but Glyph is still stubborn when it comes to games that are configured to require any minimum windows version, you basically need to make your own override configuration.

    So if you're stuck at Glyph telling you that you need at least Windows Vista, I'll make an updated guide on how to work around that.

  3. #3
    Junior Member
    Join Date
    Jul 2018
    Posts
    1
    I'm not sure why but I think my last post wasn't posted for some reason.
    .. Anyway, @lynx3d if you can, it would be great if you made a new guide since I tried your guide from 2017 and it still detected Windows XP
    (hoping this post will get through now)

  4. #4
    Oh totally missed this thread. I hope this is still working, I've been lazy updating my own Glyph, but here are the last instructions I had put together:


    Current state:
    Glyph downloads the correct game library now, but the check of the windows version still fails (this is not a wine bug, Glyph actively checks for wine because the version check is more of a hack on Windows since the official API functions don't behave to their liking in Win 10).

    Workaround:
    We need to edit the game library manually, luckily Glyph allows all kinds of messing around.

    Step 1: Launch Glyph so it downloads the remote game library into its installation directory and quit it again.

    Step 2: Setup a local game library. To do this, create a new directory that resolves to a path with drive letter inside wine.
    E.g. if you mapped "~/winestuff" to "D:", then "~/winestuff/my_glyph_library" can be found by Glyph at "D:\my_glyph_library".
    Then, move the "library_manifest.txt" and the "Library" directory (the whole directory, not just the files it contains) created in your Glyph installation by step 1 into this new directory. I say move rather than copy because leaving the original files will prevent reloading them due to checksums.

    Step 3: Edit the library to remove the version requirement, so we prevent a windows version check.
    For this, open the "Library/GlyphLibrary.xml" file in a text editor, find and remove this line in the Trove section:
    "<MinOS>winvista</MinOS>"

    Step 4: Now we need to tell Glyph to use the modified library instead of the remote files. This can be achieved with "GlyphClientApp.xml". By default this file does not exist, but there is a template for it in "GlyphClient.xml". So copy "GlyphClient.xml" to "GlyphClientApp.xml" and open it in an editor. Find the line:
    "<SelfUpdateUrl>http://glyph.dyn.triongames.com/glyph/live</SelfUpdateUrl>"
    This is the URL where Glpyh fetched the game library (library_manifest.txt etc.)
    Luckily, this URL also supports local paths with the file:// syntax. The syntax is "host/filepath". Since we don't need to specify a host, the path just starts with an extra slash, i.e. the example path above would be:
    <SelfUpdateUrl>file:///D:/my_glyph_library</SelfUpdateUrl>

    After this, Glyph should finally launch Trove without complaining about requiring Vista or later.
    Note that the remote library will change from time to time. This usually only switches out background images and does not affect patching the game, but if it stops working, you'll need to redo the process. Also, this inhibits Glyph's self updating. To restore stock behaviour, just remove "GlyphClientApp.xml".

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts