+ Reply to Thread
Results 1 to 2 of 2

Thread: Trove crashing upon startup during the "Loading Player" phase

  1. #1
    Junior Member
    Join Date
    Mar 2018
    Posts
    1

    Trove crashing upon startup during the "Loading Player" phase

    Whenever I start up Trove, it crashes in the "Loading Player" part. This problem only occurs when I'm using my account, as when using other accounts, Trove functions fine. The problem started when I joined a club world, and the game crashed. I've tried everything listed here:
    https://support.trionworlds.com/hc/e...roubleshooting
    (I'm on mac, I have both steam and glyph)
    I've deleted all my Glyph files and steam files THREE times already, and the problem persists.

    Any ideas?

  2. #2
    Junior Member
    Join Date
    Jun 2018
    Posts
    1
    Also having some serious problems with loading Trove.

    It all started the second I joined an actual world after completing the tutorial bit and returning to Home. Since then I have't been able to get it to work. I've checked every single thread I could find, and tried every solution.

    The launcher works completely fine. At first, it crashed at the same spot while loading, now it crashes the second I join a world.
    My pc was running this without problems during the tutorial.

    Any help would be appreciated.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts