+ Reply to Thread
Results 1 to 3 of 3

Thread: Issues when launching the game

Hybrid View

  1. #1
    Junior Member
    Join Date
    Nov 2016
    Posts
    9

    Unhappy Issues when launching the game

    I just recently got my primary computer, which is a Windows 10 Pro OS computer, back from the repair shop last month, and since then I have been having issues just trying to launch the game. but once I press the play button on the Glyph window, the Game's window just freezes as a white window with a functional mouse of the correct appearance. when it occurs I have to force close the game using the task manager. I have been talking with trion support since Friday and I have been getting nowhere with the given support information. plus when I check the %appdata% (Roaming) folder, the trove folder is there but the Trove.cfg file is missing. since when the computer first broke, I have been using my secondary PC to play the game and everything is completely fine there. Also, I primarily use steam to play games from trion worlds, and the other games I play from them, which are Archage and Rift are completely fine when being played. I don't know what I can do, because i called the repair shop and they are saying it is a problem with the installer at this point, i am starting to feel like i will never get this fixed. i hope that someone can help me.

  2. #2
    Did you tried to turn it off and on again?

    jokes aside - Did you tried to deinstall/remove everything related to Trove and also a fresh - if you prefer through steam - Install?
    Chipset, GPU, Windows, Glyph (Steam) everything up-to-date?

  3. #3
    Junior Member
    Join Date
    Nov 2016
    Posts
    9
    Quote Originally Posted by TheZonk View Post
    Did you tried to turn it off and on again?

    jokes aside - Did you tried to deinstall/remove everything related to Trove and also a fresh - if you prefer through steam - Install?
    Chipset, GPU, Windows, Glyph (Steam) everything up-to-date?
    I have tried a fresh install, I have updated all the drivers and even windows. everything else I play on my laptop is working properly, so I don't know what is going on. I play games from Trion Worlds, Nexon, Webzen and Gamescampus, to name a few publishers. and I play them in a mix of either the steam platform or their personal platforms since either steam doesn't carry them, or I had a account with the site before seeing them become available on steam. Also, I tried out of curiosity just installing trove straight from the trion website and I am still having the same issues even through that method of playing it.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts