+ Reply to Thread
Results 1 to 3 of 3

  Click here to go to the first Trove Team post in this thread.   Thread: Not able to connect to Trove servers.

  1. #1
    Junior Member
    Join Date
    Jan 2017
    Posts
    4

    Not able to connect to Trove servers.

    Hi, I have been unable to login to the Trove servers for close to 12 hours now, where at the start of the game I press 'Play' and it is unable to connect to the game after loading for a few minutes. It's not a network issue as I have reset every piece of hardware related to the game and internet, I also reinstalled Trove just to be certain, and I still cannot log in. I'm able to log in to other Xbox live accounts onto Trove, and any other games also work fine, it's just the one account having a problem with the servers. If anyone has any solutions to the issue, any help would be greatly appreciated. And I have also put a ticket in already, but due to conflicting time zones, I don't think I'll get a response for at least a few hours from Trion. Thanks.

  2.   This is the last Trove Team post in this thread.   #2
    Community Manager Fasti's Avatar
    Join Date
    Sep 2014
    Location
    Austin
    Posts
    5,803
    Still having trouble connecting?
    Steve "Fasti" Haines
    Community Manager, Trove
    Follow me on Twitter!

    Read our forum rules before posting, please! |Looking for help? Contact our support team! | Found a bug? Follow these steps to report it and we'll fix it ASAP!

    Follow us on Facebook and Twitter!

  3. #3
    Junior Member
    Join Date
    Jan 2017
    Posts
    4
    It's sort of alright now I guess. It's been about a week since the issue started, and after going through all the steps with your support I still don't entirely think it's a network issue as it was always working fine for me on other accounts and every other part of my internet was fine. I packed away my Xbox for a few days and when I went on again today, I factory reset it just to see if it would change anything, and now the game finally works. I can connect, though I have disconnected a few times, and at least one of those times I got to received user acknowledgment before it crashes again, but afterward it let me back on, so I don't know for how long it will all continue to work.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts