+ Reply to Thread
Results 1 to 3 of 3

Thread: Bomb crafting bug

  1. #1
    Senior Member kaizer killer's Avatar
    Join Date
    Sep 2015

    Bomb crafting bug

    Ive been seeing a increase of complaints in globe about bombs being made and takes the resources but doesn't give the bombs. Tested it and lost some bombs
    ( 'v') <(if under 20 mastery and want class coin) 17/30 ( 'v')<(forum image upload help) ( 'v')<(returning player info) ( 'v')<(if game bug report it and if brakes bad submit ticket) ( 'v')<( trove giveaways occasionally happen here but more frequent in Trovsaurus)

  2. #2
    Had similar issues with sponges...

    Usually it starts with a sponge not hitting the water but not going back in my inventory despite saying so in the loot text area. Crafting more sponges then usually makes them go to nirvana. Sometimes they show up after porting or relogging, but other times they're gone forever.

    Wonder if it has something to do with throwable items being stuck in a bad state.

  3. #3
    Junior Member
    Join Date
    Feb 2018

    Bomb crafting bug, PS4

    This is happening to me. When I try to craft Bombs, the mats get used up but nothing comes out. I thought at first that maybe I crafted the wrong type (Big Bomb) but when I tried again, the same thing happened.

    I tried going to a different map, restarting the game, rebooting the system, and even switching classes (which fixes another bug: getting stuck in fishing mode while looting (holding SQUARE) in front of water/plasma/chocolate/lava).

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts