+ Reply to Thread
Results 1 to 3 of 3

Thread: [Workaround / Solution] to "DirectX Buffer Error - Device Removed"

  1. #1
    Senior Member Blasphemy's Avatar
    Join Date
    Jun 2015
    Location
    Austria
    Posts
    110

    [Workaround / Solution] to "DirectX Buffer Error - Device Removed"

    Hi!

    After recently setting up a new Windows 7 x64 installation, I encountered this said Error "DirectX Buffer Error - Device Removed" as I launched trove. It immediately crashed me to my desktop and I got the message that my Nvidia driver had crashed and had to be restarted.

    Searching with google, I found a workaround using the OpenGL (instead of DirectX) Renderer here:
    http://forums.trovegame.com/showthre...device-removed
    The performance in OpenGL is absolutely abysmal so I continued to look for a solution using DirectX:

    Using Nvidia GeForce Experience's optimization feature for Trove, my game ran stable but at very low FPS (Supersampling 3 drops my FPS from 60+ to 30 compared to Supersampling 1). So I went back to my original settings and immediately crashed again with the same Error.

    With method of elimination it turned out that whenever I DISABLED Bloom, the Error appeared. Later noticed another Error Message "OAWrapper.exe has failed to start EC: 0xc0000142" OAWrapper (OpenAutomate Wrapper) is a software component that comes with GeForce Experience and is apparently causing the issue.

    So, to prevent this Error from appearing, I have to run the game using Bloom.
    I would recommend to find your trove.cfg file and change the corresponding entry.
    If you are using Glyph to start trove (and not steam) this file is located in %Appdata%/Trove.
    In the [Rendering] section set Bloom = true. For me this looks like
    [Rendering]preset = -1VFXLevelOfDetail = Bloom = trueBrightness = 1.000000

    Alternatively, if you're using a Nvidia graphics card you might be able to use the optimization feature of GeForce Experience like I did and then turn the other settings down.

    TL;DR:
    Turn on Bloom in the trove.cfg file and it should run again.

    I really hope that helps everyone else as well. If it does or doesn't please let me know so I can update this post accordingly.

    I want to do a shoutout here to Cypher from Customer Support who gave me a load of replies on my ticket, helping me fix this problem and not just telling me to use OpenGL and be done with it. I really appreciate the effort and our CS' diligence!
    Mastery: 470+ | SA-Misfits Leader | IGN: Blasphemy

  2. #2
    Hey, All I'm seeing is DrawDistance under the rendering bucket. Help?

  3. #3

    Dude, thanks!

    Thanks for the fix!

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts