PDA

View Full Version : Massive lag -- game unable to load worlds



sativa
03-04-2017, 09:22 PM
*Internet is running smoothly, other processes load fine*

Not sure what is causing this massive lag. Started about 20 minutes ago. Was in the hub, trying to climb tower to a portal. First got pushed back as though was hit by an enemy, tried again & eventually loaded into a world.

Upon entering biome, load looked great, everything seemed normal. But when traveling to a new biome, was pushed back again, yet there were no enemies around. Happened a couple times till it looked like I had fallen off the map.

Was actually trying to find a frontier biome but it never loaded. I was stuck in between two different biomes & unable to move or progress forward.

Exited to hub and again, lag pushed me back before I could properly enter another world. This time I tried a dungeon closer to hub portal, took enemies about 5 seconds to notice and attack (given the 1 second it takes them to notice). Right then as I was hit, ended up knocked back into the world itself. I could see inside of the dungeons (invisible walls, glitches galore) & couldn't move again but was able to use mounts, change styles, etc.

Is this going to be constant until the full release or should I leave it alone for now & try again later? Getting frustrated tbh.

Thanks in advance for any feedback.

Teaser
03-04-2017, 10:38 PM
I'm having same issues especially trying to enter my club. All of a sudden lags and crashes constantly