PDA

View Full Version : Awful Connection Lag and Disconnecting



Hyper
12-23-2016, 12:02 PM
I don't know if I'm the only one going through it or not but since th beginning of the beta on Xbox, I have not stopped lagging. Whenever I play I get horrible connection lag where enemies will stop moving completely or play will start running in a straight line forever. This has been non stop every time I play. With my game losing connection to the game server every few minutes as well it's in playable. Just need to get this out there because I hope it will be fixed. Gonna take a break from the game until something happens with this because it not even fun to play with all these problems.

Tekyn
12-23-2016, 04:43 PM
I get horrible rubberbanding sometimes. When gliding I will just teleport to the ground. I've rubberbanded so far back that I end up further in the opposite direction than I've gone.

There are constant DCs and timeouts while trying to transition to a new area. Today I needed to run to Sky Realm for 3 minutes to get some mats for crafting. It took me 4 tries to get my club world to load (it just timed out and dropped me in the hub). Once there, I had to go through the same ordeal to get into the Sky Realm portal, except I now had to make it back to the club world first before I could try again. Then I had the same problems trying to get back to the club world after I was done getting my mats. What should have taken 5 minutes took about 20-25 minutes, most of which was spent staring at the loading screen.

And lets not get into trying to get through a whole Shadow Tower without DCing.


I've come to the conclusion that the knight on the loading screen doesn't have a scar... that's a tear running down his cheek, because he's been stuck on that loading screen forever. And now I know his pain.